Tagged: 

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #3248

    gbell_spamless
    Participant

    After a recent update, I’m getting this:

    Catchable fatal error: Argument 1 passed to GmediaCore::array_diff_keyval_recursive() must be an array, null given, called in /home/plcg4637/public_html/wp-content/plugins/grand-media/inc/shortcodes.php on line 98 and defined in /home/plcg4637/public_html/wp-content/plugins/grand-media/inc/core.php on line 466

    Wordpress 3.9.1. Gmedia is all updated.

    #3261

    Rattus
    Keymaster

    Be sure you have also latest module versions on Modules page.

    #3296

    gbell_spamless
    Participant

    Oops, my bad. Gmedia is now at 1.1.2. But I get this:

    Notice: Undefined variable: default_options in /home/plcg4637/public_html/wp-content/plugins/grand-media/inc/shortcodes.php on line 93

    Catchable fatal error: Argument 1 passed to GmediaCore::array_diff_keyval_recursive() must be an array, null given, called in /home/plcg4637/public_html/wp-content/plugins/grand-media/inc/shortcodes.php on line 98 and defined in /home/plcg4637/public_html/wp-content/plugins/grand-media/inc/core.php on line 466

    #3301

    Rattus
    Keymaster

    I’ve talked about Gmedia modules (not wordpress plugins). Go to Gmedia -> Modules page -> update modules to latest versions.

    #3307

    gbell_spamless
    Participant

    Those errors are all from Gmedia core, aren’t they?

    Under admin.php?page=GrandMedia_Modules I show 5 installed modules, but none show any need for update:

    #3310

    Rattus
    Keymaster

    Try re-save gallery settings. Go to Manage Galleries page -> click on gallery title to edit it -> click Save button to update settings in database.
    If not helps then the problem could be in the module you use for current gallery (module could be corrupted, so it can’t load default options).
    Try change module for gallery. Go to Edit gallery and click on module image on top left -> in popup choose another module for current gallery -> Save gallery with new module.

    #3314

    gbell_spamless
    Participant

    I re-saved gallery settings – no change.

    I was unable to change the module for the gallery. There was no module image on the top left of the edit gallery screen. The error is displaying on that screen, so perhaps it is preventing the page from rendering properly:

    Editi gallery

    #3316

    gbell_spamless
    Participant

    Also, notice these galleries are “photobox”, which I just noticed shows up on the “not installed” section. I can’t install it via the Modules page (a vague “Filesystem error” even though there are write permissions). If I unzip it to grand-media/modules, it still isn’t detected.

    #3318

    gbell_spamless
    Participant

    Hi Rattus,

    Good news! I found the problem. Somehow, there was a wp-content/grand-media/modules/photobox directory (version 0.3). shortcodes.php was finding this one instead of the new one in wp-content/plugins/grand-media/modules/photobox. What a pain to find!

    rm’ing the bogus/old one in wp-content/grand-media/modules/photobox made everything start working again.

    I’m not sure what caused this – I didn’t do it manually, so I’m suspecting Gmedia installed there originally. Why it wasn’t updating it is beyond me. Ultimately this is due to Gmedia since I didn’t start mucking around in there until it broke.

    Thanks for the support. I think I’m all good now.

    In attempt to repay the favour, I’ll point out you have a broken link on http://wordpress.org/plugins/grand-media/. It points to https://codeasily.com/portfolio-item/gmedia-photobox/ which doesn’t exist. Also, the Gmedia Modules page within WordPress points the Photobox demo to https://codeasily.com/portfolio-item/gmedia-photobox/ which also doesn’t exist :)

    Thanks again.
    Greg

    #3326

    Rattus
    Keymaster

    Thanks for point me on broken links.
    In ‘/wp-content/plugins/grand-media/module‘ folder should be only bundled free modules. All other modules should be in ‘/wp-content/grand-media/module‘ folder, so when you update plugin – modules which you install manually will not be erased. If the same module is in both places – plugin’s folder will be ignored.

Viewing 10 posts - 1 through 10 (of 10 total)

The forum ‘Troubleshooting’ is closed to new topics and replies.

Forum closed. Use forum at Wordpress.org: Gmedia Support Forum