Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #3353

    gbell_spamless
    Participant

    Hi,

    My thumbnails in my Photobox galleries are not proper thumbnails – they’re cropped to thumbnail size, rather than scaled.

    http://plcg.net.au/flora-and-fauna/amphibians/

    Have I done something wrong, or is that a bug?

    #3373

    Rattus
    Keymaster

    I’ll fix it in future module update. For now go to edit gallery and on “Advanced Settings” tab add to Custom CSS:

    div.photobox_module .gmPhotoBox li a img { max-height: 100% !important; }
    #3376

    gbell_spamless
    Participant

    That works as a work-around, thanks.

    But of course it squashes any images that aren’t 1:1 aspect ratio.

    There’s a good CSS3 trick which actually centres the crop (overflow: hidden and background-position: center center) but apparently that’s not supported in IE7.

    Another option is to position and crop the images in the UI and have the thumbs on disk already cropped.

    Actually there’s one more – you could inline-style a negative margin based on the dimensions of the thumbnail… a 100×120 image would need a top margin of -10px to center it. You’d also have to decide whether to set max-height OR min-height (only one) depending on which dimension was least.

    #3377

    Rattus
    Keymaster

    Actually there’s one more

    That’s how in Phantom module now. I’ll update Photobox soon with few more options and implement the same technique as in Phantom.

Viewing 4 posts - 1 through 4 (of 4 total)

The forum ‘Troubleshooting’ is closed to new topics and replies.

Forum closed. Use forum at Wordpress.org: Gmedia Support Forum